Information - Azure Front Door facing configuration issues

Incident
November 05, 6:42pm EST

Information - Azure Front Door facing configuration issues

Status: closed
Start: October 29, 12:04pm EDT
End: November 05, 6:42pm EST
Duration: 7 days 7 hours 37 minutes
Affected Components:
Cloud Providers Azure Azure Frontdoor
Update

October 29, 12:04pm EDT

October 29, 12:04pm EDT

Between 15:45 UTC on 29 October and 00:05 UTC on 30 October 2025, customers and Microsoft services leveraging Azure Front Door (AFD) experienced latencies, timeouts, and errors.

The AFD & CDN delivery services continue to be stable and are running as expected. 

Out of an abundance of caution, all service management operations (including creation, updates, deletions, and purges) to AFD via portal or APIs continue to remain temporarily suspended. We are working on a comprehensive plan to gradually reenable these in a phased approach, while ensuring the platform remains stable.

We will continue to share periodic updates as we make progress. Next Update will be by 01:00 UTC on 31 Oct 2025 or sooner.

Update

October 30, 9:08pm EDT

October 30, 9:08pm EDT

The Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remains at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable. 


We will notify customers once the restriction is lifted, and we will be sending periodic communication on the progress. Next Update will be by 19:00 UTC on 31 Oct 2025 or sooner as event warrant.

Update

October 31, 4:03pm EDT

October 31, 4:03pm EDT

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable.  

 

We are working to provide an ETA on when we can lift the restriction and will continue sending periodic communication on the progress via Azure Service Health. The next update will be by 19:00 UTC on 01 November 2025 or sooner as events warrant.

Update

October 31, 5:35pm EDT

October 31, 5:35pm EDT

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable.  

 

Our current expectation is to lift the restriction on 05 November 2025, and we will continue sending periodic communication on the progress via Azure Service Health. The next update will be by 19:00 UTC on 01 November 2025 or sooner as events warrant.

Update

November 01, 3:41pm EDT

November 01, 3:41pm EDT

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable.  

 

Our current expectation remains to lift the restriction on 05 November 2025, and we will continue sending periodic communication on the progress via Azure Service Health. The next update will be by 19:00 UTC on 02 November 2025 or sooner as events warrant.

Update

November 02, 3:31pm EST

November 02, 3:31pm EST

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable. 

 

Our current expectation remains to lift the restriction on 05 November 2025, and we will continue sending periodic communication on the progress via Azure Service Health. The next update will be by 03:00 UTC on 03 November 2025 or sooner as events warrant.

Update

November 02, 4:07pm EST

November 02, 4:07pm EST

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable. 

 

Our current expectation remains to lift the restriction on 05 November 2025, and we will continue sending periodic communication on the progress via Azure Service Health. The next update will be by 03:00 UTC on 03 November 2025 or sooner as events warrant.

Update

November 02, 10:02pm EST

November 02, 10:02pm EST

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable.

Our current expectation remains to lift the restriction on 05 November 2025, and we will continue sending periodic communication on the progress via Azure Service Health. The next update will be by 19:00 UTC on 03 November 2025 or sooner as events warrant.

Update

November 03, 7:14pm EST

November 03, 7:14pm EST

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As part of completing our full investigation and safe checks, performing service management operations (create, update, delete, purge, etc.) were made temporarily unavailable. 

Restrictions on service management operations have been removed for this Azure subscription ID. Please allow approximately 30–40 minutes for changes to fully propagate to edge sites. We expect all restrictions across subscriptions, including other subscriptions under your tenant, to be lifted by 05 November 2025. Updates on progress will continue via Azure Service Health. The next update will be provided by 22:00 UTC on 04 November 2025, or sooner if circumstances change.

Update

November 03, 7:25pm EST

November 03, 7:25pm EST

We acknowledge that previous communication may have contained information meant for another list of customers. We apologize for the inconvenience and request you to note the following.

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable. 

The workflow to manage and rotate Bring Your Own Certificate (BYOC) certificates has been re-enabled. We will monitor the progress of working through the queue of necessary rotations. We will continue to provide regular updates on progress. Our current expectation remains to lift the restriction on 05 November 2025. The next update will be by 22:00 UTC on 04 November 2025 or sooner as events warrant.

Update

November 03, 10:27pm EST

November 03, 10:27pm EST

In preparation for lifting the service management restrictions, an incorrect communication was sent indicating an early removal. Our current date for lifting all control plane restrictions remains 05 November 2025. The next update will be provided by 22:00 UTC on 04 November 2025, or sooner.

Update

November 04, 5:22pm EST

November 04, 5:22pm EST

Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated at 00:05 UTC on 30 October 2025 and remain at normal operating levels. As we complete our full investigation and implement further safe checks, service management operations (create, update, delete, purge, etc.) are temporarily unavailable. 

We continue to hit our milestones toward the expectation to lift this restriction on 05 November 2025. The next update will be sent to confirm once this has happened, or sooner if events warrant.

Update

November 05, 6:36pm EST

November 05, 6:36pm EST

Latest Update: As of 23:00 UTC on 5 November, 2025 restrictions on Azure Front Door (AFD) and Content Delivery Network (CDN) service management operations have been removed. You may now resume normal operations on the AFD service management plane. For enhanced safety and protection, we have extended the configuration propagation times up to 45 minutes. Additional platform enhancements which are underway are expected to optimize the propagation times further.

Previous Context: Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated by 00:05 UTC on 30 October 2025 and remain at normal operating levels. We previously notified you that, as part of completing our full investigation and safe checks, performing service management operations (create, update, delete, purge, etc.) were temporarily restricted. This notification is to confirm that those temporary restrictions no longer apply.

Next Steps: As mentioned in our Preliminary PIR we are completing an internal retrospective to understand the incident in more detail. Once this is completed, which is expected within approximately 7 days, we will publish our final Post Incident Review (PIR) - including a link to register for an Azure Incident Retrospective livestream, discussing the incident and our learnings.

Azure Front Door frequently asked questions (FAQ) | Microsoft Learn

Resolved

November 05, 6:42pm EST

November 05, 6:42pm EST

 Latest Update: As of 23:00 UTC on 5 November, 2025 restrictions on Azure Front Door (AFD) and Content Delivery Network (CDN) service management operations have been removed. You may now resume normal operations on the AFD service management plane. For enhanced safety and protection, we have extended the configuration propagation times up to 45 minutes. Additional platform enhancements which are underway are expected to optimize the propagation times further.

Previous Context: Azure Front Door (AFD) and Content Delivery Network (CDN) delivery data planes were fully mitigated by 00:05 UTC on 30 October 2025 and remain at normal operating levels. We previously notified you that, as part of completing our full investigation and safe checks, performing service management operations (create, update, delete, purge, etc.) were temporarily restricted. This notification is to confirm that those temporary restrictions no longer apply.

Next Steps: As mentioned in our Preliminary PIR we are completing an internal retrospective to understand the incident in more detail. Once this is completed, which is expected within approximately 7 days, we will publish our final Post Incident Review (PIR) - including a link to register for an Azure Incident Retrospective livestream, discussing the incident and our learnings.

Azure Front Door frequently asked questions (FAQ) | Microsoft Learn