Status pages and admin application unavailable

Incident
April 05, 5:00pm EDT

Status pages and admin application unavailable

Status: closed
Start: April 03, 8:19pm EDT
End: April 03, 9:03pm EDT
Duration: 44 minutes
Affected Components:
Status pages Admin application
Update

April 03, 8:19pm EDT

April 03, 8:19pm EDT

At approximately 8:19PM EDT, StatusCast’s engineers were alerted that some status page and admin applications were inaccessible. The team identified that its hosting partner, Microsoft, was experiencing some issues in its US East region related to app services and SQL databases connections. As of 9:03PM EDT services have been restored and StatusCast’s team is currently working with Microsoft to fully investigate the incident. Once the team has completed it’s investigation we will follow up with an RCA.

At this time StatusCast should be operating fully as expected, if you continue to have any further issues please contact us at support@statuscast.com

Resolved

April 03, 9:03pm EDT

April 03, 9:03pm EDT

As of 9:03PM EDT services have been restored and StatusCast’s team is currently working with Microsoft to fully investigate the incident. Once the team has completed it’s investigation we will follow up with an RCA.

Root Cause

April 05, 5:00pm EDT

April 05, 5:00pm EDT

In working with Microsoft, StatusCast’s team confirmed that the disruption was due to an outage with SQL Databases located in Azure’s US East region which is where StatusCast is primarily hosted: 




StatusCast itself was impacted by this outage from approximately 8:19 PM EDT and had fully recovered by 9:03 PM EDT. StatusCast’s team will continue to work closely with Microsoft to further optimize its offering to help ensure that impact of service provider outages is as minimal as possible.