SMS Delivery Delays To Telefonica Network In Mexico

Informational
March 08, 11:23am EST

SMS Delivery Delays To Telefonica Network In Mexico

Status: closed
Date: March 08, 10:01am EST
Affected Components:
Cloud Providers Twilio
Investigating

March 08, 10:01am EST

March 08, 10:01am EST

We are experiencing SMS delivery delays when sending messages to Telefonica Network In Mexico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Investigating

March 08, 10:12am EST

March 08, 10:12am EST

We are continuing our investigation and have discovered SMS Latin America is affected by SMS delivery delays when sending messages to Telefonica Network in Mexico.

Monitoring

March 08, 11:22am EST

March 08, 11:22am EST

We are observing recovery in SMS delivery delays when sending messages to Telefonica Network in Mexico. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.