On Call Engineers Are Investigating an Issue Related to SMS Delivery Delays

Informational
February 26, 2:39am EST

On Call Engineers Are Investigating an Issue Related to SMS Delivery Delays

Status: closed
Date: February 26, 1:43am EST
Affected Components:
Cloud Providers Twilio
Investigating

February 26, 1:43am EST

February 26, 1:43am EST

Our monitoring systems have detected a potential issue related to SMS delivery delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Investigating

February 26, 1:54am EST

February 26, 1:54am EST

We are experiencing SMS delivery delays when sending messages to the Safaricom network in Kenya. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Monitoring

February 26, 2:38am EST

February 26, 2:38am EST

We have observed a recovery from SMS delivery delays when sending messages to the Safaricom network in Kenya. We are monitoring the service to ensure a full recovery, and we will provide another update in 2 hours or as soon as more information becomes available.