Programmable Messaging Callback Failures

Incident
May 22, 2:07pm EDT

Programmable Messaging Callback Failures

Status: closed
Start: May 22, 12:08pm EDT
End: May 22, 2:07pm EDT
Duration: 1 hour 59 minutes
Affected Components:
Cloud Providers Twilio
Investigating

May 22, 12:08pm EDT

May 22, 12:08pm EDT

We've become aware of a potential issue with SMS status callbacks. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Investigating

May 22, 12:28pm EDT

May 22, 12:28pm EDT

We are experiencing delays in delivering message callbacks to our customers. Our engineers are working to restore the service. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Investigating

May 22, 12:34pm EDT

May 22, 12:34pm EDT

We are experiencing failures in delivering a subset of final message status callbacks (DELIVERED/UNDELIVERED) to our customers. Our engineers are working to restore the service. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Monitoring

May 22, 1:04pm EDT

May 22, 1:04pm EDT

We are observing recovery with the failures in delivering a subset of final message status callbacks (DELIVERED/UNDELIVERED) to our customers. Our engineers will continue to monitor to ensure a full recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Monitoring

May 22, 1:26pm EDT

May 22, 1:26pm EDT

The issue with failures in delivering a subset of final message status callbacks (DELIVERED/UNDELIVERED) has been resolved and Programmable Messaging is operating normally at this time.

Resolved

May 22, 2:07pm EDT

May 22, 2:07pm EDT

The issue with failures in delivering a subset of final message status callbacks (DELIVERED/UNDELIVERED) has been resolved and Programmable Messaging is operating normally at this time.