Status page and admin portal degraded performance event

Incident
May 10, 7:06pm EDT

Status page and admin portal degraded performance event

Status: closed
Start: May 10, 4:11pm EDT
End: May 10, 7:06pm EDT
Duration: 2 hours 55 minutes
Affected Components:
Status pages Admin application
Update

May 10, 4:11pm EDT

May 10, 4:11pm EDT

StatusCast engineers have detected a possible performance impacting event affecting status pages and the admin application. This event is not impacting notification processing. We apologize for this inconvenience and will provide an update shortly. 

Resolved

May 10, 7:06pm EDT

May 10, 7:06pm EDT

This event has been resolved.