Multiple delays in email deliverability

Incident
April 25, 12:03pm EDT

Multiple delays in email deliverability

Status: closed
Start: April 25, 10:02am EDT
End: April 25, 12:03pm EDT
Duration: 2 hours
Affected Components:
Cloud Providers SendGrid
Monitoring

April 25, 10:52am EDT

April 25, 10:52am EDT

At 7:30 A.M. PT on April 25, 2023, our engineers identified and mitigated the issue that was causing delivery delays to some SendGrid customers and are currently monitoring traffic to ensure delivery. We will provide another update within an hour

Resolved

April 25, 12:03pm EDT

April 25, 12:03pm EDT

Our engineers have monitored the fix and confirmed the issue with delay in deliverability has been resolved. All services are now operating normally at this time.