SendGrid SMTP/API mail send failures

Informational
March 02, 12:54am EST

SendGrid SMTP/API mail send failures

Status: closed
Date: March 01, 11:34pm EST
Affected Components:
Cloud Providers SendGrid
Identified

March 01, 11:34pm EST

March 01, 11:34pm EST

We have recently rolled out a new certificate change for SMTP and API while some clients are experiencing compatibility issue with new certificate.

Identified

March 01, 11:59pm EST

March 01, 11:59pm EST

Our engineers have identified the issue and are working towards mitigation. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

March 02, 12:54am EST

March 02, 12:54am EST

Certificate rollback has been completed for SMTP and API. We are still monitoring performance to make sure that the issue has been fully resolved.