Messages Failures Over A2P to T-Mobile

Incident
January 20, 4:55pm EST

Messages Failures Over A2P to T-Mobile

Status: closed
Start: January 20, 2:07pm EST
End: January 20, 4:55pm EST
Duration: 2 hours 47 minutes
Affected Components:
Cloud Providers Twilio
Investigating

January 20, 2:07pm EST

January 20, 2:07pm EST

Our monitoring systems have detected a potential issue with A2P. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.

Investigating

January 20, 2:23pm EST

January 20, 2:23pm EST

We are investigating an issue causing message delivery failures for a subset of messages sent over A2P to T-Mobile. We expect to provide another update in 1 hour or as soon as more information becomes available.

Investigating

January 20, 3:11pm EST

January 20, 3:11pm EST

We continue to investigate an issue causing message delivery failures for a subset of messages sent over A2P to T-Mobile. We expect to provide another update in 2 hours or as soon as more information becomes available.

Monitoring

January 20, 4:38pm EST

January 20, 4:38pm EST

We are observing recovery in message delivery failures for a subset of messages sent over A2P to T-Mobile. We will continue to monitor to ensure full service recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.

Resolved

January 20, 4:55pm EST

January 20, 4:55pm EST

We are no longer experiencing SMS delivery failures to a subset of messages sent over A2P to T-Mobile. This incident has been resolved.