Sending failures US

Informational
February 21, 3:28pm EST

Sending failures US

Status: closed
Date: February 21, 1:36pm EST
Affected Components:
Cloud Providers Mailgun
Update

February 21, 1:36pm EST

February 21, 1:36pm EST

We are currently investigating this issue.

Update

February 21, 1:38pm EST

February 21, 1:38pm EST

We are continuing to investigate this issue.

Update

February 21, 1:40pm EST

February 21, 1:40pm EST

We are continuing to investigate this issue.

Update

February 21, 1:52pm EST

February 21, 1:52pm EST

We are continuing to investigate this issue.

Update

February 21, 1:58pm EST

February 21, 1:58pm EST

We are continuing to investigate this issue.

Update

February 21, 2:15pm EST

February 21, 2:15pm EST

A fix has been implemented and we are monitoring the results.