EU Region Sending Delays

Incident
February 14, 3:17pm EST

EU Region Sending Delays

Status: closed
Start: February 14, 9:23am EST
End: February 14, 3:17pm EST
Duration: 5 hours 53 minutes
Affected Components:
Cloud Providers Mailgun
Update

February 14, 9:23am EST

February 14, 9:23am EST

We are currently investigating the issue. This is limited to EU customers.

Update

February 14, 10:05am EST

February 14, 10:05am EST

We are continuing to investigate the issue.

Update

February 14, 11:27am EST

February 14, 11:27am EST

The investigation is well underway. Sending delays continue in the EU.

Update

February 14, 11:32am EST

February 14, 11:32am EST

A fix has been implemented and we are monitoring the results.

Resolved

February 14, 3:17pm EST

February 14, 3:17pm EST

This incident has been resolved.